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This Quick Start also explains what you need to do before you begin installing the
system. Refer to the ProcessLogix Hardware Installation Instructions, publication
1757-5.1 for information on the components that make up your ProcessLogix
System
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.
ATTENTION

The ProcessLogix server runs on Microsoft Windows NT 4.0
(Service Pack 5). Only Service Pack 5 is Y2K compatible.

The tasks described in this QuickStart represent a sample program. This program is
not intended for actual process control applications. After you have completed the
tasks in this sample program, you can use the sample to guide you as you program
your own process control application.
When completing the tasks in this Quick Start, always use the parameter names we
suggest so that the pre-built screens provided with the ProcessLogix system work
correctly.

Important User Information
Because of the variety of uses for the products described in this publication, those
responsible for the application and use of this control equipment must satisfy
themselves that all necessary steps have been taken to assure that each application
and use meets all performance and safety requirements, including any applicable
laws, regulations, codes and standards.
The illustrations, charts, sample programs and layout examples shown in this guide
are intended solely for purposes of example. Since there are many variables and
requirements associated with any particular installation, Allen-Bradley does not
assume responsibility or liability (to include intellectual property liability) for actual
use based upon the examples shown in this publication.
Allen-Bradley publication SGI-1.1, Safety Guidelines for the Application, Installation
and Maintenance of Solid-State Control (available from your local Allen-Bradley
office), describes some important differences between solid-state equipment and
electromechanical devices that should be taken into consideration when applying
products such as those described in this publication.
Reproduction of the contents of this copyrighted publication, in whole or part,
without written permission of Rockwell Automation, is prohibited.
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Throughout this manual we use notes to make you aware of safety considerations:
ATTENTION

Identifies information about practices or circumstances that
can lead to personal injury or death, property damage or
economic loss

Attention statements help you to:
• identify a hazard
• avoid a hazard
• recognize the consequences
IMPORTANT

Identifies information that is critical for successful application
and understanding of the product.

Allen-Bradley is a trademark of Rockwell Automation

European Communities (EC) Directive Compliance
If this product has the CE mark it is approved for installation within the European
Union and EEA regions. It has been designed and tested to meet the following
directives.

EMC Directive
This product is tested to meet the Council Directive 89/336/EC Electromagnetic
Compatibility (EMC) by applying the following standards, in whole or in part,
documented in a technical construction file:
• EN 50081-2 EMC — Generic Emission Standard, Part 2 — Industrial
Environment
• EN 50082-2 EMC — Generic Immunity Standard, Part 2 — Industrial
Environment
This product is intended for use in an industrial environment.
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Low Voltage Directive
This product is tested to meet Council Directive 73/23/EEC Low Voltage, by
applying the safety requirements of EN 61131-2 Programmable Controllers, Part 2 Equipment Requirements and Tests. For specific information required by EN
61131-2, see the appropriate sections in this publication, as well as the
Allen-Bradley publication Industrial Automation Wiring and Grounding Guidelines
For Noise Immunity, publication 1770-4.1.
This equipment is classified as open equipment and must be mounted in an
enclosure during operation to provide safety protection.
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Before You Begin
Before you begin installing the system, ensure that you have already:
•
•
•
•
•

installed the chassis and power supply
installed the 1757-PLX52 Process Controller module
installed the CNB Module
installed the analog and digital I/O modules you want to use in your system
set up and configured the ProcessLogix server

We tell you how to do all of these tasks in the ProcessLogix Hardware Installation
Instructions, publication 1757-5.1.

TIP

The ProcessLogix server is shipped from the factory with the
software already installed.

Starting the Software
In this section, we tell you how to start:
• The ProcessLogix server program
• Control Builder software

TIP

The System Repository, a database that contains information
about your control environment, and the CDA program
(which controls communications between ProcessLogix server
applications and RSLinx communication software) are
Windows NT Services that start automatically.
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Verifying ControlNet nodes and I/O modules
The CDA program starts up RSLinx and all configured drivers for ControlNet
communications from the server to the controller backplane.
You should verify at least once the ControlNet nodes and the I/O modules you will
be using in your system. For purposes of illustration, we are using two ControlNet
nodes in this manual:
• a ControlNet module with address 1 at slot 0 in the chassis (To set the node
address, adjust the rotary switches on top of the module. See the schematic
on the right side of the module for a guide to selecting the address), and
• the ProcessLogix server at ControlNet address 20 (set in RSLinx Software)
If the LED on the front of the ControlNet module reads ERR,
no other ControlNet devices are present on the network.

TIP

Verify the ControlNet nodes using NTOOLS:
1. To view chassis configuration click on:
Start

⇒ Programs ⇒ ProcessLogix Engineering Tools ⇒ NTOOLS.

2. Click OK
3. Click on NetworkTools

⇒ Settings.

4. Select the Ping radio button.
5. Click OK.
6. Click on NetworkTools

⇒ Ping.

7. Click on 01CNI. Set the chassis slot setting to match your chassis size (this is
a one-time setting).
8. Verify that all I/O modules appear as configured in the chassis.
9. Exit NTOOLS by clicking on NetworkTools ⇒ Exit.
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Starting the ProcessLogix server
The ProcessLogix Server program is the operating system for the ProcessLogix
server. To start the server:
1. Click on:
Start

⇒ Programs ⇒ ProcessLogix Server ⇒ Start-Stop ProcessLogix Server.

2. On the dialog box that appears, click on Start. If server is already started,
skip to next section.
3. A dialog box asking you if you are sure you want to start the server appears.
Click on Yes.

TIP

You may experience a delay while the system launches all
server tasks and services

Turning off areas
“Areas” are portions of a process you wish to control. This Quick Start assumes that
areas are turned off. To turn off areas:
1. Click on Start

⇒ Programs ⇒ ProcessLogix Server ⇒ Station.

2. Select Configure

⇒ Areas.

3. Access manager mode.
a. Click on “Oper” in the bottom right of
the screen. You see a flashing cursor
in a box in the upper right corner of
the screen (below the toolbar).
b. Type mngr (lower case).
c. Press the Enter key. “Oper” changes to “Mngr”.
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4. To disable areas, uncheck the Areas Enabled checkbox

5. Close the Station screen.

Starting Control Builder
Control Builder software is an application you use to develop Control Module and
Sequential Control Modules. The Control Modules and Sequential Control Modules
are downloaded to the 1757-PLX52 Process Control Module.
To start Control Builder:
1. Click on:
Start

⇒ Programs ⇒ ProcessLogix Engineering Tools ⇒ Control Builder

Control Builder starts up displaying a “tree” view. We describe the available
trees in the following table:

this tree view:

shows you:

Project

the offline copy of your project

Loaded/Monitoring

The loaded or runtime (currently monitoring) copy of the application
executing on the 1757-PLX52 Process Controller module

Library

• available I/O modules (IOM)
• available function blocks for use in Control Modules
• available function blocks for use in Sequential Control
Modules

Once you have opened Control Builder, you can begin configuring your
hardware.
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Creating a Controller
The first step in configuring your hardware is creating a controller.
1. To create a controller:
2. In Control Builder, select File ⇒ New ⇒ Controller ⇒ C200. Realize that
C200 = PLX52. You see the New Controller dialog box.

3. On the New Controller dialog box, select the following:
in this field:

select:

CPM Slot Number

01

“Uplink” MAC Address

01 (for the ControlNet CNB card)

TIP

As you enter the CPM slot number and the uplink MAC
address, notice the CPM Name and CEE Name fields on the
bottom half of the New Controller screen. You will see that
the CPM name is assigned automatically. The software also
provides a default name for your CEE. You can change the
CEE name by clicking on the CEE name field and typing a
new name.
If you want to change the CEE name, do so now, since the
CEE name references all screen and tag names in the server
database.

4. Click on OK.
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5. To see your newly configured CPM and CEE, click the Project tab.

TIP

To see the CPM and CEE, you may need to expand the
ProjectRoot branch of your tree by clicking on the small “+”
sign to the left of the word Root.

The CEE is listed under the CPM and is connected directly to it. This tells
you that the CEE is assigned to the CPM.
6. Enter the server parameters by following these steps:
a. Under the Project tab, double-click on the CPM0101 icon.
b. To display the server parameters form, select the Server Parameters tab.
c. Enter the following parameters (non-case-sensitive):
in this field

for the CPM, enter

for the CEE, enter

Point Detail Page

sysdtlcpma.dsp

sysdtlceea.dsp

Group Detail Page

sysgrpcpma.dsp

sysgrpceea.dsp

d. Click on OK.
7. Load the CPM and the CEE:

TIP

Loading the CPM also loads the corresponding CEE.
To see the CPM and CEE, you may need to expand the
ProjectRoot branch of your tree by clicking on the small “+”
sign to the left of the word Root.
The CPM should appear green

a. In the project tab, click on CPM0101.
b. From the Toolbar Menu, click on the green down arrow.
c. A “Load” dialog box appears. Verify the selected object is CPM0101, and
click on Continue.
d. To verify the loaded CPM and CEE, click on the Monitoring Tab.
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Configuring I/O Modules
Once you have created a controller, the next step is to configure the
I/O modules you will use in your system.
Before you can configure a module, you must add it from the library to your
project:
1. Click on the Library tab.
2. Click the + to the left of the I/O icon to see a list of available modules.

3. Create the I/O module blocks by dragging and dropping these templates
from the Library tab to the Project tab (on the second tree display).
Be sure to add the modules in the order listed here so that ProcessLogix
automatic module numbering conventions work correctly.
– 6-channel isolated analog input module (1756-IF6I)
– 6-channel isolated analog output module
(4-20 MA; 1756-OF6CI)
or
– 6-channel isolated analog output module
(voltage output; 1756-OF6VI)
and
– 16-channel isolated digital input module (24V DC; 1756-IB16I)
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– 16-channel isolated digital output module
(24V DC: 1756-OB16I)

TIP

You see the modules displayed after the heading IOM under
Project Root.

Configuring analog input modules
To configure the analog input modules:
1. Double-click on the IOM with the lowest number after it (for example,
IOM8). This will bring up the configuration screen for the 6-channel isolated
analog input module (1756-IF6I).

TIP

IOM8 is an example of the automatic module numbering
convention. We will provide you with an example module
number as we show you how to configure all the I/O
modules. The module numbers you see in your application
may vary.

On the IOM Configuration screen that is displayed, select the Main tab.
in this field:

enter:

Module Name

LabAI

IOM Slot Number

the slot number containing this module
(remember that chassis numbering begins with
0)

Remote I/O Chassis Mac Address

0

CNI Slot Number

0
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2. Select the Channel Configuration tab.
3. On the Channel Configuration screen that is displayed, enter this
information:
in this field:

select:

Input Range

0V to 10V

Notch Filter

60Hz

4. Click on the Server Parameters tab.
5. On the Server Parameters screen, enter these parameters
(non-case-sensitive):
in this field:

enter:

Point Detail Page

sysdtlaia.dsp

Group Detail Page

sysgrpaia.dsp

6. Click on OK.

Configuring analog output modules
To configure the analog output modules:
1. Double-click on the IOM with the lowest number after it (for example,
IOM9). This will bring up the configuration screen for the 6-channel isolated
analog output module (1756-OF6CI; current output, or 1756-OF6VI; voltage
output).
2. Click on the block for this module and select Configure Parameters.
3. On the IOM Configuration screen that is displayed, select the Main tab.
in this field:

enter:

Module Name

LabAO

IOM Slot Number

the slot number containing this module

Remote I/O Chassis Mac Address

0

CNI Slot Number

0
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4. Select the Channel Configuration tab.
5. On the Channel Configuration screen that is displayed, enter this
information:
in this field:

enter:

Shed Mode

unchecked (de-select the check mark)

Calibration Bias

0

6. Click on the Server Parameters tab.
7. On the Server Parameters screen, enter these parameters
(non-case-sensitive):
in this field:

enter:

Point Detail Page

sysdtlaoa.dsp

Group Detail Page

sysgrpaoa.dsp

8. Click on OK.

Configuring digital input modules
To configure the digital input modules:
1. Double-click on the IOM with the lowest number after it (for example,
IOM10. This will bring up the configuration screen for the 16-channel, 24V
DC isolated analog input module (1756-IB16I).
2. On the IOM Configuration screen that is displayed, select the Main tab.
in this field

enter

Module Name

LabDI

IOM Slot Number

the slot number containing this module

Remote I/O Chassis Mac Address

0

CNI Slot Number

0

3. Select the Module Configuration tab.
4. In the Filter Times for Channels 0 -7 field, select 1 msec for all channels.
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5. In the Filter Times for Channels 8 -15 field, select 1 msec for all channels.
6. Click on the Server Parameters tab.
7. On the Server Parameters screen, enter these parameters
(non-case-sensitive):
in this field

enter

Point Detail Page

sysdtldia.dsp

Group Detail Page

sysgrpdxa.dsp

8. Click on OK.

Configuring digital output modules
To configure the digital output modules:
1. Double-click on the remaining IOM with a number. This will bring up the
configuration screen for the 16-channel, 24V DC isolated analog output
module (1756-OB16I).
2. On the IOM Configuration screen that is displayed, select the Main tab.
in this field:

enter:

Module Name

LabDO

IOM Slot Number

the slot number containing this module

Remote I/O Chassis Mac Address

0

CNI Slot Number

0

3. Click on the Server tab.
4. On the Server Parameters screen, enter these parameters
(non-case-sensitive):
in this field:

enter:

Point Detail Page

sysdtldoa.dsp

Group Detail Page

sysgrpdxa.dsp

5. Click on OK.
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Assigning Modules to a Controller Execution Environment
Once you have configured I/O modules, you must assign them to the controller
execution environment (CEE).
To assign modules to the CEE:
1. From Control Builder, select Tools⇒Assign.
You see the Controller Assignment screen.

2. On the Assignment screen that appears, click on the IOMs tab in the
Available Modules area of the screen.
3. Select all four modules.(To select all four modules, click on the first module,
hold down the Shift Key and click on the last module).
4. Select the correct CEE from the CEE list box.
5. Click on Assign. After a few seconds, you see the IOMs displayed in the
Assigned Modules list box.
6. Select all of the IOMs from the Assigned Modules List box.
ATTENTION

Load only the I/O Modules that physically exist in the chassis.

7. Click on Load. When prompted, click OK to Load Project Version.
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8. Click on Continue to load the selected items to the CEE.

TIP

After the input modules are loaded from Control Builder, the
status LEDs stop blinking and glow steady green on the
hardware input module.
The output module will continue to flash until the 1757-PLX52
is put into run mode, and the I/O are activated.

9. Close the Controller Assignments dialog box.

Creating a PID Loop
The next step is to create a Control Module to control a process. In this example,
we will create a PID loop.

Creating the Control Module
To create the Control Module:
1. Create a new Control Moduledule by clicking on
File ⇒New ⇒ Control Module.
You see a blank window for the Control Module in the center of your
screen.

2. Rename the Control Module:
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a. Double-click anywhere in the palette. You see the Parameter
Configuration screen.
b. In the Name field, enter FIC102.
3. Click on the Server tab.
4. On the Server Parameters screen, enter these parameters
(non-case-sensitive):
in this field

enter

Point Detail Page

sysdtlpida.dsp

Group Detail Page

sysgrppida.dsp

5. Click on OK to close the Parameter Configuration screen.
6. Save your changes by clicking on File ⇒ Save. Notice that the new Control
Module name appears in the Project Tab.
7. Close Control Module FIC102

Assigning the Control Module to the Controller Execution
Environment
To assign the Control Module for our PID loop to the CEE:
1. From Control Builder, click on Tools

⇒ Assign.

2. On the Controller Assignments dialog box, select the CMs/SCMs tab.
3. Select FIC102 from the list box in the Available Modules area of the screen.
4. Click on Assign. The FIC102 module is displayed in the Assigned Modules
list box.
5. Close the Controller Assignments dialog box.
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Building the PID Loop
To develop the PID loop:
1. In the Project tab, open the control drawing by clicking on FIC102.
2. Display the available function blocks by clicking on the “+” to the left of the
appropriate library in the tree display.
3. To select a block, click on it.
4. To move the block to your diagram, drag it to the area of the palette where
you want it.
5. Rename the block by double-clicking on the block to bring up the
Parameters Configuration dialog box.
6. Add the following function blocks to the Control Module. Double click on
each block to change the name according to the chart below.
function block

name

AICHANNEL

AI00

DATAACQ

DACA

PID

PIDA

AOCHANNEL

AO00

NUMERIC

TIP

By matching this naming convention you will be able to use
the standard displays associated with Station.
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Wire the blocks
The Numeric block you created enables us to simulate a control loop. For this
loop to work properly, do not wire the AICHANNEL block.

1. Double-click on the source wire. The cursor changes to a “+”.
2. Click on the destination wire.

TIP

For additional wire segments as you draw your wire, click the
left mouse button.
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Configure parameters
1. On the Numeric block, double-click in the gray area. You see the Numeric
Parameters Configuration screen.
2. Enter these parameters:
in this field

enter

PV

10.0

3. Click on OK.
4. On the PID block, double-click in the gray area. You see the PID Parameters
Configuration screen.
5. Click on the Algorithm tab.
6. Enter these parameters:
in this field

enter

T1

.1

T1 High Limit

2.0

High Gain Limit

2.0

Overall Gain

.5

7. Click on OK.
8. On the AICHANNEL block, double-click in the gray area. You see the
AICHANNEL Parameters Configuration screen.
9. Enter these parameters:
in this field

select

Module Name

LabAI

Currently Assigned Slots

Channel 0

10. After you have selected Channel 0, click on Assign Channel and click OK.
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11. On the AOCHANNEL block, double-click in the gray area. You see the
AOCHANNEL Parameters Configuration screen.
12. Enter these parameters:
in this field

select

Module Name

LabAO

Currently Assigned Slots

Channel 0

13. After you have selected Channel 0, click on Assign Channel and click OK.

Enter alarms
1. Double-click on the DATACQ block to display the Parameters Configuration
screen.
2. Click on the Alarms tab.
3. Enter these alarms:
IMPORTANT

You must enter the PV High alarm first to enable the PV High
High alarm.

type

trip point

priority

severity

PV High

85

High

0

PV High High

95

Urgent

0

4. Click on OK.

Save and exit
1. Save your changes by clicking on File
2. Close Control Module FIC102.

Publication 1757-QS020A-US-P - December 1999

⇒ Save, or close the diagram.

ProcessLogix R200.3 Quick Start

23

Downloading the Function Block Diagram to the 1757-PLX52
Process Control Module
Use one of these two methods to download your function block diagram to the
controller module.

Method 1
1. In Control Builder, select “=” from the toolbar to display the Module
Assignment screen.
2. In the Assigned Modules list box, select FIC102.
3. Click on Load. Click on OK to load the Project Version. Click on Continue to
load the selected object to the CEE.
4. When the load is complete (status bar at 100%; Load Complete message
displayed), close the Controller Assignment dialog box.

Method 2
1. In the Project tab, click on FIC102.
2. From the Toolbar Menu, click on the green down arrow to download the
function block diagram.
3. Click on Continue to load the selected object.

Changing the Controller Execution Environment for the
1757-PLX52 Process Control Module from Inactive to Active
To execute your program, you must change the CEE from inactive to active. If the
CEE is not already activated, follow these steps to change it to active:
1. In the Monitoring tab, click on CEE0101.
2. Select Operate ⇒ Αctivate This CEE and its IOMs and CMs.
You see the CEE and everything listed under it in the tree view under the
Monitoring tab go solid green.
3. Click on Yes to change the state of the selected objects.
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Verifying Proper Operation
Follow these steps to verify that your PID loop operates properly:
1. In the Monitoring tab, double-click on FIC102. The PID diagram opens.
2. On the PID block, look at the MODE parameter to ensure that it is set to
MAN (manual).
3. With the PID block in manual mode, double-click on the OP parameter and
set it to 80.
4. On the PID block, double-click on the MODE parameter and set it to AUTO
(automatic).
5. Double-click on the setpoint wire and set the setpoint to 25.0.
6. Verify that the PID OP output value (displayed near the wire) changes.
7. Change the NUMERIC.PV to 20, then 30. Observe the OP output of the PID
block for changes.
8. Close the diagram without saving your changes.

Viewing Pre-built Screens
To view the pre-built screens provided with the ProcessLogix system:
1. If the Station application program is not running, click on:
Start

⇒ Programs ⇒ ProcessLogix Server ⇒ Station.

Publication 1757-QS020A-US-P - December 1999

ProcessLogix R200.3 Quick Start

25

2. Click on the text box in the upper right
corner of the screen (below the
toolbar).
to view the detail screen for the:

do this

controller

1. Type CPM0101 in the box.
2. Press [F12].

CEE

1. Type CEE0101 in the box.
2. Press [F12].

PID loop

1. Type FIC102 in the box.
2. Press [F12].

I/O modules

1. Type the name of the I/O module in the box.
2. Press [F12].

alarms

Click on the red, blinking alarm indicator at the bottom of
the screen, or click on the Alarm icon in the toolbar menu.

Shutting Down the System
Follow this procedure to shut down your system in an orderly manner:
Before shutting down the system, verify that the process being controlled is
off-line.
1. Close all open Control Modules in Control Builder.
2. To close Control Builder, from the main menu, select
File ⇒ Exit.
3. To close Station, in the Station application widow, select Station

⇒ Exit.

4. Unload the database:
a. Select Start ⇒ Programs ⇒ ProcessLogix Server ⇒ Start-Stop
ProcessLogix Server.
b. Ensure that the window is in the Full mode view. To do this:
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• Left-click your pointer in the upper
left corner of the Server Start-Stop
dialog box.
• Choose Advanced

⇒ Full mode.

c. Click the Database Unloaded radio button.
d. When asked to confirm, click Yes.
e. When the server changes states, close the dialog box.
5. Shut down the System Repository:
a. From Windows NT, select Start

⇒ Settings ⇒ Control Panel.

b. Double-click on the Services icon. You see the Services dialog box.
c. Select the PlantScape System Repository service by highlighting it.
d. Click the Stop button to shut down the System Repository and the CDA
server.
e. Shut down RSLinx:
– From Windows NT, select Start
–
–
–
–

⇒ Settings ⇒ Control Panel.

Double-click on the Services icon. You see the Services dialog box.
Select RSLinx by highlighting it.
Click the Stop button to shut down RSLinx.
Close the Services dialog box.

6. Close any open windows.
7. Shut down the Windows NT workstation.
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Notes:
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