Technical Data

PanelBuilder32 Software
Version 3.80
Version 3.80 of the PanelBuilder32 software supersedes version 3.70 as the
configuration tool for the PanelView Standard terminals.

Version 3.80 Features

This section lists new or updated features in Version 3.80. These features
require terminal firmware version 4.20 (or later) in the PanelView Standard
terminals.

Resizing Bitmaps
You can now resize bitmaps (including imported bitmaps and ISA symbols).
Bitmaps can be resized when you:
• add a bitmap to a screen by selecting Objects>Graphics>Graphic
Image
• add a bitmap to an object in inner graphic mode (Format>Inner
Graphic)
PanelBuilder32 maintains the bitmap in its original size and modified sizes.
When adding a bitmap to a screen which has been resized, PanelBuilder32 will
open a dialog allowing you to select an existing size or a new size.

Import/Export Graphics Dialog
The Import/Export Graphics dialog has been updated to include
additional support.
When you open a bitmap for importing, the dialog shows:
• size of bitmap (in pixels) and number of colors
• view of the bitmap (if enabled)
• view of the bitmap as it would appear using the 32-color palette of the
target PanelView terminal (if enabled)
• view of the bitmap as black and white image (if enabled)
The dialog has a Color reduction method area for bitmaps with a
greater number of colors than what is supported by the target PanelView
terminal (32 colors). These bitmaps must be reduced in number of colors
using one of the color reduction methods. Select the option that provides the
best image. Select the Preview with terminal palette check box to view what
the image will look like on the target PanelView terminal.
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Searching for a Tag
You can now search for all occurrences of a single tag in the current
application using the Tag Search dialog. This includes tags that are used by
screen objects as well as objects that do not appear on the screen, such as
embedded variables or print objects. You can access the Tag Search dialog in
the following ways:
• In the Tag Editor, select a tag to search for, right-click and select Used
By from the shortcut menu.
• Right-click on a screen object and select a tag from the Tag Search
submenu.
In the above 2 cases, the Tag Search dialog opens, showing all occurrences of
the selected tag in the application. A GoTo button is available to navigate to a
specific screen using the tag.
Another way to search for a tag is to select Edit>Tag Search. When the Tag
Search dialog opens, select the tag you want to search for and click the
Search button.

Counting and Purging Tags
To check for unused tags or how may times a tag is used in the application,
select Tools>Tag Count. A dialog opens listing the names of all tags in the
application and the number of times the tag is used. Tags not used by the
application have a Usage Count of 0. You can purge unused tags with the
Purge button.

Float Support for MicroLogix Controllers
The MicroLogix 1200 and 1500 controllers now support the Float file type.

Color Palette
PanelBuilder32 now supports a 32-color palette for PanelView Standard color
terminals with firmware 4.10 or later.
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This section lists new or updated features in Version 3.70. These features
require terminal firmware version 4.20 or later.

EtherNet/IP Support
The PanelView 550, 600, 900, 1000 and 1400 terminals now support
EtherNet/IP communications. Dialogs have been added to configure
communications for the PanelView terminal and logic controller on an
EtherNet/IP network. The EtherNet/IP PanelView terminal can
communicate with the following controllers:
• ControlLogix Ethernet/Gateway through a 1756-ENET/B or
1756-ENB module
• PLC-5E or PLC-5 with 1761-NET-ENI or 1785-ENET module
• SLC-5/03, 5/04, or 5/05 with 1761-NET-ENI module
• MicroLogix, CompactLogix or FlexLogix with 1761-NET-ENI module
The Tag Editor supports a Tag Form dialog and EtherNet/IP worksheets to
configure Controller Address, CIP or Assembly Object tags.

FlexLogix and CompactLogix Support
The DF1 and DH-485 PanelView terminals now support communications
with FlexLogix and CompactLogix controllers. The Communication Setup
dialog for these terminals includes FlexLogix and CompactLogix as Node
Type selections.

Sizing and Moving Objects using Keyboard Keys
You can now use the arrow keys (up, down, right, left) on your keyboard to
resize objects. Select the object, hold down the Shift key and press an arrow
key. The up and down arrow keys decrease or increase the size of the object
vertically. The right and left arrow keys decrease or increase the size of the
object horizontally.
To move an object, select the object and press the up, down, left, or right
arrow key to move the object up, down, left or right.

Resizing Analog Gauge Needles
When you resize a gauge, the needle is also resized. The needle is resized using
the smallest dimension (height or width) of the gauge. The needle maintains its
same relative position to the gauge.
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Global Object Enhancements
Locating and placing global objects is now more convenient because of
features added to the Global Objects dialog. To access this dialog, select
Objects>Global Object. New features include:
• Used By button - Select a global object and then click the Used By
button to display a list of screens where the object is used. You can
navigate to any screen by clicking the Go To button in the Screens
dialog.
• Sort By box - sorts global objects by tag name, ID, object type or
description.
• There are 2 methods for placing a global object on a screen.
Double-click a global object in the list or select a global object and click
the Copy To button. Position the crosshair (+) in the screen where you
want to drop the object and left-click.

Text Object Editing
The Text object now supports the Text Edit dialog for entering/editing text.
To access the Text object, select Objects>Text. You can now double-click on
a text object to enter text (and variables) directly in the Text Edit dialog. This
is in addition to entering text using the Inner Text tool bar.

Text Alignment Defaults
The Objects tab on the Options dialog has two new fields which allow you
to set the default text alignment for all objects. One field lets you set the
horizontal alignment (left, center, right) and another field lets you set the
vertical alignment (top, middle, bottom). To access the Options dialog, select
Tools>Options.
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This section lists new or updated features in Version 3.61. These features
require terminal firmware version 4.10 or later.

RSLinx Software
PanelBuilder32 software now supports RSLinx 2.2 software.

Multiple Language Support
You can now store text for up to 5 different languages in an application
including English, French, German, Italian and Spanish. By storing translated
text for objects in the application, you can easily change the language as
needed while the application is running on the terminal. The 5 languages can
be selected at any time, changing the language in the objects throughout the
entire application. Only one language is active for the application at one time.
To enable multiple language support for a new application, select the
Multiple Language Support check box on the Create New
Application dialog. To convert an existing application to support multiple
languages, select the Multiple Language Support check box on the
Terminal Setup tab of the Application Settings dialog.

Capture Manager Dialog
The Capture Manager dialog, available from the Screen menu, provides a
convenient way to capture one or more screens in the current application and
copy them to:
• clipboard
• .bmp file
• import the bitmap images into the current application
You can capture screens at their normal size, thumbnail size (64 x 64 pixels) or
a percentage of the normal size. Multiple screens can be saved to a single or
separate .bmp files. When saving multiple screens to a single .bmp file, the
images can be saved in a horizontal row, one per row, or as a specific number
of images per row. You can also specify a background color for the images.

Bar Graph Inner Text
You can now specify inner text or an inner graphic for bar graphs similar to
other objects.

Scrolling Text
Use the scrolling text object to create screen text that scrolls from left to right
at a set rate. This object is useful when screen space is limited.

Vertical Alignment/Centering Tools
The Inner Text toolbar now has tools for aligning inner text at the top, middle
or bottom of the object.
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Enhanced Data Types
PanelBuilder32 supports three new data types:
• DINT or 32-bit signed integer is supported in objects where the 16-bit
INT data type is valid. The DINT data type has a range of
-2,147,483,648 to 2,147,483,647 and occupies 2 words (4 bytes or 32
bits) of memory.
• SINT or 8-bit signed integer is supported in objects where the 16-bit
INT data type is valid. The SINT data type has a range of -128 to 127.
Negative values are stored as 2’s compliment values.
• BOOL data type is supported in objects where the bit data type is valid.
True is 1; False is 0.

RS-Logix 5000 Support
The tag editor now lets you import or export RS-Logix-5000 tags in a CSV
(*.csv) file format including tag names, tag addresses and tag descriptions.
(User defined structures will import tag names and tag descriptions).

MicroLogix L Data Files
PanelBuilder32 and the PanelView terminals now support the Long Word (L)
File on the MicroLogix 1200 and 1500 controllers.

Write to Controller on Startup
On the Advanced tab of the Application Settings dialog, you can disable
the Write to Controller on Startup via a check box for DeviceNet terminals
using Explicit Client tags and for ControlNet terminals that use Unscheduled
message tags. However, for DeviceNet terminals that use I/O or Explicit
Server tags and ControlNet terminals that use Scheduled messages, preset
values are always written to the controller on startup regardless of the setting.
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Analog Gauge
The analog gauge uses a rotating needle to display a process variable such as
speed, temperature or pressure. The gauge consists of a circular scale with
tick-marks, 1 to 4 needles, and a label with text or variable data. The circular
scale is an integral part of the gauge but can be created separately. To access
this object, select Objects>Graphic Indicators>Gauge.

Circular Scale
A circular scale is available with or without major/minor tick marks on the
inside or outside of the scale. You can adjust the minimum/maximum angles
for the scale. You can even disable the scale, so just the tick marks are visible.
To access the circular scale, select Objects>Graphic
Indicators>Scales>Circular. This object can be used as a secondary scale
with an analog gauge.

Numeric Entry Inc/Dec
The Inc/Dec object is similar to the numeric entry Cursor Point object but
updates a numeric value in predefined steps. Select Objects>Numeric
Entry>Inc/Dec to access this object.

Screen Security
PanelBuilder32 provides security features that allow you to restrict screen and
terminal access (including configuration screens) to authorized operators. You
can also create screens that would allow authorized operators to select and
change the passwords of other operators at the terminal.
Most security features, including operator authorization parameters, are
accessed from the Application>Security dialog. However, you can secure
individual screens from the Screen>New or Properties dialog. Special keys
that are used to change operator passwords at the terminal, login/logout of the
terminal, or disable security on the terminal are accessed from the
Objects>Security Keys submenu.

Text Edit dialog
The new Text Edit dialog is available in inner text mode to facilitate the
editing of text and inserting variables. To access this dialog, enter inner text
mode and then click the down arrow located on the right side of the Text
Edit box.

Tag Editor
The tag editor has a new and improved look and feel including:
• Worksheets (by protocol) for entering and editing tags by protocol. For
applications that use shared projects, the All Tags worksheet is available
to show tags that have common fields across protocols.
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• You must use the Save tool or File>Save Project command to save tags
before you can use them with your application. You can also save tags to
a tag editor draft file *.tdf for work in progress.
• Automatic error checking of tags for missing or required information
when saving tags. A read-only Errors worksheet opens if errors or
warnings are found. View>Error submenu commands and tools are
available to navigate through errors in the Errors worksheet.
• The Tag Form dialog is no longer needed, nor available, within the Tag
Editor, only from the object’s dialog.
• Locate and replace text in a column using the Edit>Replace command.
• Filter tags based on the contents of a cell to view just a portion of the
worksheet using the Filter icon.
• The Tag Edit tab of the Tools>Options dialog has options for
converting tags when an application is converted to run using another
protocol and for creating tag names based on the address field.

Publication 2711-TD005D-EN-P - March 2002 8
Supersedes Publication 2711-TD005C-EN-P - May 2001

41061-160-01(4)
Copyright © 2002 Rockwell Automation. All rights reserved. Printed in the U.S.A.

